WordPress’den gelen bilgilere göre WordPress 5.5 sürümünden kaynaklı milyonlarca site etkilenmiş durumda ve bundan dolayı WordPress 5.5.1 bakım sürümü, sitelerin bozulmasını önlemek için tasarlandığı bildirilmiştir. Ancak hataların yine de düzeltilmesi gerekeceği bilgisi geldi.

WordPress 5.5 de yer alan ve aşağıda listelenen global JavaScript nesneleri çıkarıldı.

Çıkarılan JavaScriptler:

attachMediaBoxL10n

authcheckL10n

commentL10n

commonL10n

inlineEditL10n

navMenuL10n

postL10n

plugininstallL10n

privacyToolsL10n

setPostThumbnailL10n

tagsl10n

tagsSuggestL10n

userProfileL10n

wp.themePluginEditor.l10n

wp.updates.l10n

wpColorPickerL10n

wpPointerL10n

wpWidgets.l10n

Bu, bu nesnelere başvurmanın bir JavaScript hatasıyla sonuçlanacağı ve dolayısıyla JavaScript’in yürütülmesini durduracağı anlamına geliyor. Bu nesnelerin bazıları çok popüler eklentilerde ve temalarda kullanılıyordu. @omarreiss  ve @joostdewalk bu neslerin nerede kullanıldığını araştırdılar. Çıkan sonuç  Google sayfasında Gösterilmektedir.

WordPress 5.5 hataları

Joost De Walk yayınladığı açıklamada;

“Yalnızca 100 binden fazla veya daha fazla yüklemeye sahip eklentileri veya temaları sayarsak, bunlardan bazıları zaten inanılmaz bir etkiye sahiptir. Bu yüzden bunu mümkün olan en kısa sürede düzeltmeye karar verdik”

WordPress 5.5.1 sürümünün yayınlanma zamanı konusunda ise açıklama aşağıdaki şekilde duyuruldu.

önerilen WordPress 5.5.1 zamanlama , nihai sürüm için beklenen 1 Eylül 2020 Salı 21:00 GMT + 3 . Lütfen bu tarih / saatin RC2 test edilirken keşfedilen sorunlara bağlı olarak değişebileceğini unutmayın.Konu hakkında detayları buradan öğrenebilirsiniz.

5.5.1 sürümü 44 açığı kapatıyor. Daha fazla bilgi için dağıtım notlarına bakın.