
eb Tasar›m›, son birkaç y›l›n
en popüler alanlar›ndan biri.
Bu konuda birbirine alternatif
çok program bulunuyor. Üste-
lik iyi bir tasar›m sadece tasa-

r›m bilmekle bitmiyor maalesef. Ucun-
dan k›y›s›ndan programc›l›k, en az›n-
dan kod bilginizin olmas› gerekiyor.

Baflar›l› olman›n anahtar› çok ça-
l›flmak ve bunu yaparken de program-
lar aras›nda bo¤ulmamay› baflarmak.
Afla¤›da bulunan ipuçlar›n›n, sizleri
bu konuda rahatlataca¤›na inan›yo-
ruz. Yaz›da yer alan programlar›, flu s›-
ralar Web tasar›m›nda en çok kullan›l-
d›klar›n› düflündüklerimizden seçtik.
Yani Dreamweaver, Flash, Fireworks
ve Photoshop. Bu bölümlerde prog-
ramlar› kullan›rken iflinize yarayacak
ipuçlar› ve daha pek çok fleyi bulacak-
s›n›z. Di¤erleri bölümünde, tasar›m
yaparken dikkat etmeniz gereken nok-
talar›, Web’de imaj kullan›m flekilleri-
ni, baz› faydal› kod tavsiyelerini bula-

caks›n›z. Kod ve programc›l›k alan›nda
tavsiyeleri s›n›rl› tuttuk. Çünkü o bafl-
l› bafl›na bir alan. ‹puçlar›n›, farkl› se-
viyelerden derledik ki bunlardan her-
kes faydalanabilsin. Laf› fazla uzatma-
dan ipuçlar›na geçelim dilerseniz...

MAC ÖZEL
Türkçe Web Fontlar›m›z Haz›r m›? 
Web, bugün için sadece Arial, Comic
Sans MS, Courier, Helvetica, Times,
Verdana sans-serif gibi s›n›rl› birkaç
fontu destekliyor. Mac’in standart sis-
tem fontlar› içinde bu fontlar›n hepsi
ne yaz›k ki ‘Türkçe karakterleri içere-
cek flekilde’ bulunmuyor. Sorunu gi-
dermek için bu eksik fontlar› ayr›ca
yüklemek gerekiyor. Yukar›da bahset-
ti¤imiz Türkçe fontlar› ve bu dokü-
manda bahsi geçen di¤er yaz›l›m ve
materyalleri http://www.aycango-
nenc.com sitesindeki MacLine linkin-
den edinebilirsiniz. 

CSS’i ‹flletim Sistemine Ayarlamak
Ayn› CSS dosyas› Mac ve Windows’da
farkl› sonuçlar verir. Yaz›lar Win-
dows’da Mac’dekinden daha küçük ve
daha koyu görünür. Bu nedenle önce
Windows’a göre bir css dosyas› haz›r-
lan›r (ör: win.css). Sonra ikinci bir dos-
ya mac’de farkl› olacak de¤erlere göre
haz›rlan›r (ör: mac.ss). <link
href=”win.css” rel=”styleSheet”
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type=”text/css”> tag’› html belgesinin
(Ör: homepage.html) <HEAD> k›sm›na
eklenir. Ard›ndan flu JavaScript kodu-
nu devam›na ekleriz: 
<script language=”JavaScript”>
if ( (navigator.appVersion.homepageOf
(‘Mac’) !=-1) ) {
document.write (‘>link href=”mac.css”
rel=”styleSheet” type=”text/css”>’ ) ; }
</script>

Gamma da Ha!
Renklerin yans›tt›¤› ›fl›k de¤eri
Mac’ler için 1.8 iken PC’lerde 2.2’dir.
Durum böyle olunca Mac’te haz›rlad›-
¤›n›z bir resim ya da grafik PC’de afl›-
r› koyu görünebilir. Bunun için, Ma-
cintosh kullan›c›lar› taray›c›lar›n›n
kulland›¤› arayüzdeki gamma de¤eri-
ni 2.2 olarak de¤ifltirmelidirler. Tara-
nan resme Mac’te bak›ld›¤›nda çok
aç›k, soluk gelebilir ama PC’de izle-
yenler resmi normal görecektir.

Mac’de PC Görüntü Kontrolü
Bir tasar›m› PC ekran›ndaki gibi gö-
rüp, çal›flma imkan› veren birçok yar-
d›mc› var. Bunlardan en kullan›fll›s›
“GammaToggle FKEY”. GammaToggle
FKEY ayn› bir font gibi çal›fl›yor.
www.aycangonenc.com sitesindeki
MacLine linkinden ulaflabilece¤iniz
program› indirdi¤inizde klasör içinde
iki tane font çantas› göreceksiniz,
“GammaToggle FKEY” ve “Gamma-
Toggle FKEY no show”. Bu fontlardan
birini Sistem Klasörü içindeki Font
Klasörüne yerlefltirin, sonra (Elma +
option + 9) tufllar›na ayn› anda bas›n.
Bu ifllemi ard arda yapt›¤›n›zda, moni-
tör ayarlar›n›z›n s›ras›yla (Mac Gam-
ma), (PC Gamma) ve (Saved Gamma)
olarak de¤iflecektir. 

Perl, CGI ve PHP Script’lerde 
Türkçe Karakter Problemi
Internet’ten indirdi¤iniz scriptin için-
deki yaz›lar› Türkçelefltirdi¤inizde,
Türkçe karakterler sitenizde do¤ru gö-
rünmeyebilir. Çözüm, her karakterin
Latin5 ASCII karfl›l›¤›n› bulup “Find &
Change” yöntemi ile de¤ifltirilmesinde-
dir. Bu ifli sizin yerinize yapan “Charo-
ma Converter” program›n› kullanmak
en kolay yöntem. Bunun için önce
scripti (Örn: guestbook.php), bir text
editörü ile aç›n (ör: BBEditLite) ve
Türkçelefltirmek istedi¤iniz sat›rlar›
yaz›n. Doküman› kaydedin ve Charo-
ma Converter’in üzerine sürükleyip b›-
rak›n. Program, doküman›n 3 ayr› ver-

siyonunu yarat›r (.L5, .L1 ve .Mac
uzant›l›). Guestbook.php.L5 dosyas›-
n›n sonundaki (.L5) uzant›s›n› silip,
döküman› yine text editörü ile aç›p en
sondaki yaz›y› silin. Guestbook.php
script’ini Web alan›n›za yükleyin.

PHOTOSHOP’TA WEB
Photoshop ile Pratik Resim Galerisi
Resim galerisi tutkunlar› için Photos-
hop’un da önerece¤i pratik bir özelli¤i
var. HTML tabanl› bir resim galerisi
yaratman›za yard›m edecek olan araç,

File > Automate komutu yoluyla ula-
flaca¤›m›z Web Photo Gallery arac›. Bu
komutla karfl›m›za ç›kan menüdeki
flablon, ölçü birimleri, resimlerin al›-
naca¤› ve resimlerin saklanaca¤› dos-
ya bilgileri girildikten sonra OK buto-
nuna basar›z. Photoshop otomatik ola-
rak hemen resimleri boyutland›r›r,
yerlefltirir ve haz›rlad›¤› HTML dosya-
s›n› önünüze getirir.

Renkleri Saydamlaflt›r›n
Bir resmin baz› bölümlerini saydam
yapmak için Photoshop’da flu ad›mlar›
izleyin:

Resmi programda aç›n; Image >
Mode > Indexed Color seçene¤iyle res-
mi dönüfltürün. File’dan Export me-
nüsünü seçin ve Gif89aExport seçene-
¤ini t›klay›n. Aç›lan Options pencesin-
den görünmez olmas›n› iste¤iniz rengi
seçin. OK tufluna bas›n ve GIF olarak
kaydedin.

Herfley S›rayla
Bir foto¤raf editöründe çal›fl›rken res-
minizi boyutland›rmay› en son yap›n.
Brightness, contrast ve renk ayarlar›-
n›n, resmin en yüksek piksel bilgisine
sahipken yap›lmalar› daha iyi sonuç
verir. Crop’lama ve boyut de¤ifltirme
ise son ad›m olmal›d›r. 

Dijital Foto¤raf›n›z› Düzeltin
Ço¤u dijital foto¤raflar›n temizlenmeye
ihtiyac› yoktur. Ama bazen istisnalar
olabilir. Bu foto¤raflar› Photoshop’un
healing brush ve rubber stamp arac›
ile düzeltebilirsiniz.

Photoshop ile Web Sayfas› Tasar›m›
Photoshop ile Web tasar›m› yapmak is-
teyenler olabilir. (Tabii PS 6 ya da 7
kullan›lmal›) Öncelikle canvas size’›
700X600 pixel olan (sitenizin büyük-
lü¤ünü ne olacaksa) yeni bir dosya
aç›n. Sitenizin görünmesini istedi¤iniz
imaj›n tasar›m›n› yap›n. Araç çubu¤u-
nun en alt›nda bulunan ImageReady
dü¤mesine t›klayarak program› aç›n.
Slice arac›n› kullanarak sayfan›zdaki
tablolar› oluflturun. ‹maj›n›z› optimize
edin ve çal›flman›z› kaydedin. 

ImageReady’de Animasyon
Yeni bir belge aç›n ve ilk kareye iste-
nen nesneyi koyun. Ekran›n alt›ndaki
“Animation” panelinden yararlan›n.
Yeni kareler ekleyin ve üzerlerinde ge-
rekli de¤ifliklikleri yap›n. Frame paleti
ile animasyonun kaç kere oynat›laca-
¤›n› belirleyin. File > Save Optimized
komutu ile animasyonu .gif uzant›s›y-
la kaydedin.

DREAMWEAVER T‹PLER‹
Dreamwever’a Türkçe destek 
San›r›m Dreamweaver MX’in tek eksi-
¤i Türkçe deste¤inin olmay›fl›. Ama
bunun da kolay bir yolu var.
www.macline.com.tr/users/ftp_ml/
D W _ M X _ t r _ e n c o d i n g . e x e
indirece¤iniz eklentiyle Dreamweaver
MX’iniz mükemmel olacak. Tabii
program› kurduktan sonra Modify
menüsünden Page Properties’i seçip
gereken ayarlar› yapman›z gerekiyor.
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Ayn› fley Edit menüsü alt›ndaki Prefe-
rences seçene¤inde de yap›lmal›. Pre-
ferences’daki New Document ve Fonts
bölümlerinde Türkçe seçenekleri aktif
hale getirilmelidir.

Karmafl›k Tablolar› Hafifletin
Dreamweaver MX’de tablolar› çabuk
ve etkili hale getirmek çok kolay. 500
kolon ve 4 sat›rdan oluflan, bir sürü
bilgi ile dolu bir tabloya sahip oldu¤u-
muzu düflünelim. Böyle bir tablonun
yüklenmesi ve sunulmas› 56k bir mo-
dem ile yaklafl›k 4 dakika sürer. Biraz
olsun tabloyu rahatlatmak için kod
içinde  <colgroup> tag›n› kullana-
ca¤›z. Bu tag browser’a, haf›zas›n-
da belli miktardaki sat›r ve sütun-
lar için belli bir miktar bir yer ay›r-
mas›n› söyler. Böylece browser tab-
lonun yüklenmesi bitmeden önce
tablonun tasla¤›n› yarat›r. Bunun
için HTML kodunuza <table> <colg-
roup span=”1” width=”80%”>
</colgroup> <tr> <td> </td> </tr>
</table> kodlar›n› yerlefltirmeniz
gerekiyor. 

Link Vermenin Kolay› Var
Bir metin ba¤lant›s› yarat›rken ço¤u
Dreamweaver kullan›c›s› metni mouse
ile seçer ve sonra da ya properties pa-
nelindeki link alan›na link verir ya da
ayn› panelde link alan›n›n yan›ndaki
Point to File ikonuna t›klayarak ilgili
html dosyas›na yönlendirme yapar.
Ama link vermenin daha h›zl› bir yolu
var. Link verilecek metin seçilir ve son-
rada klavyedeki Shift tuflu bas›l› iken
linklenecek dokümana mouse ile direk
yönlendirme yap›l›r. 

Dreamweaver’da Flash’s›z Flash Butonu
Flash metinlerine benzer bir flekilde,
Dreamweaver’da Flash kullan›lmadan
yap›lan bir di¤er özellik de interaktif
butonlard›r. Hatta iflin en güzel taraf›
da butonlar› yapm›yor olmam›z. Çün-

kü Dreamweaver üzerinde 40’a yak›n
Flash butonu bulunuyor. Insert > Inte-
ractive Images > Flash Button komutu
ile önünüze haz›r pek çok buton örne-
¤i gelecek. Aç›lan menüden tercihleri-
niz yap›p OK’e bast›¤›n›zda butonunuz
sayfan›za eklenmifl oluyor. 

TimeLines ile Hareketli Bafll›k Yap›m›
Önce sayfan›za bir layer ekleyin ve içi-
ne yaz› yaz›n (bafll›k). Windows > Ot-
hers > Time Lines komutu ile zaman
çizelgesini aç›n. Çizelge penceresinde
hareketlendirmek istedi¤iniz kata t›k-
lay›n ve ilk frame’i seçtikten sonra Mo-

dify > Time Lines > Add Objects to Ti-
me Line komutunu verin. Varsay›lan
olarak animasyon 15 çerçevedir. Fakat
bu de¤ifltirilebilir. Bu kat› anime ede-
bilmek için son frame’i seçin. Çal›flma
alan›nda kat› hareket ettirin (yana
do¤ru). Design panelindeki Behaviors
sekmesini aç›n ve + iflaretli menüden
Show/Hide layer› seçin ve onMouse-
over action’›n› verin. Fare ile bafll›¤›n
üstüne gelindi¤inde bafll›k (yana do¤-
ru) hareket edecektir. 

Bul ve De¤ifltir
Ço¤u bilgisayar program›nda bir stan-
dart haline gelen Bul ve De¤ifltir özelli-
¤i Dreamweaver’da da vard›r. Bu özel-
lik yard›m›yla site çap›nda ya da dizin
çap›nda kod, renk ya da herhangi bafl-
ka birfleyi aray›p baflka bir fley ile de-
¤ifltirebilirsiniz. Asl›nda arama-de¤ifl-
tirme özelli¤i makinemizde bulunan
herhangi bir klasörde de çal›flmakta-
d›r. Kaynak kodlar›nda, metinlerde,
özel taglarda bulunan herhangi bir fley
kolayca bulunup de¤ifltirilebilir.

Flash’›n Boyutunu De¤ifltirmek
Diyelim ki sayfan›za yerlefltirdi¤iniz bir
Flash filminin boyutunu de¤ifltirmeye
karar verdiniz. Filmin boyutunu, t›klan-
d›¤›nda üzerine gelen tutamaçlarla yap-
maya kalkarsan›z en-boy oran›n› bozar-
s›n›z. O nedenle tutamaçlarla boyut ve-

rirken Shift tuflunu da bas›l› tutun.

.HTM’yi .HTML Yap›n
Dreamweaver’da HTML dosyalar defa-
ult olarak .htm olarak kaydedilmekte-
dir. Al›flkanl›klar›na ba¤l› olanlar için
bu durumu de¤ifltirmenin bir yolunu
gösterece¤iz. Öncelikle makinenizdeki
“Macromedia / Dreamweaver MX /
Configuration / DocumentTypes /
MMDocumentTypes.xml” dosyas›na
ulafl›n.

Burada program›m›z›n geniflletme
ayarlar› bulunmaktad›r. Fakat dokü-
man› Dreamweaver’da kesinlikle AÇ-

MAMAK gerekiyor. Doküman üze-
rindeki de¤ifliklikler Notepad ya da
HomeSite editörü kullan›larak ya-
p›lmal›. Dosya üzerindeki macfile-
e x t e n s i o n = “ h t m , h t m l ,
shtml,shtm,stm,lasso,xhtml,inc”
kodu 

m a c f i l e e x t e n s i -
on=”html,htm,shtml,shtm,stm,las-
so,xhtml,inc” kodu ile de¤ifltirilme-
lidir. (Windows için “winfileextensi-
on”)

Dreamweaver’da fiipflak Resim Galerisi
Otomatik thumbnail sayfas› olufltur-
mak tuhaft›r ki program›n en az bili-
nen özelliklerinden biridir. Bir sürü ifl-
lemle u¤raflmak yerine yapaca¤›n›z ilk
fley Commands > Create Web Photo Al-
bum komutunu vermek. Sonra aç›lan
menüde resimlerinizin bulundu¤u kla-

sörü ve yenilerinin kaydedilece¤i bir
di¤er klasörü tan›mlamak ve iste¤iniz
formatlar› seçmek gerekiyor. Resim
galerisi sayfan›z haz›rd›r...

Sayfa Renkleri için Otomatik fiablonlar
Dreamweaver’›n haz›r fonksiyonlar›n-
dan biri olan Set Color Sheme sayfa-
n›zdaki renk kombinasyonu’nu oto-
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matik olarak oluflturmak için kullan›-
lan haz›r renk ayarlamalar›d›r. Böylece
linklerimizi, rengi sayfa background
rengini ve metin renklerini otomatik
olarak ayarlam›fl oluyoruz. Commands
> Set color sheme command komutu-
nu çal›flt›rarak kullan›l›yor.

Sat›r Bofllu¤u
Yaz› yazarken ya da baflka nesneler
aras›nda Dreamweaver sadece tek bir
bofllu¤a izin verir. Bu sorunu kod ala-
n›nda boflluk verece¤imiz yere, istedi-
¤imiz kadar boflluk için o kadar
&nbsp;  kodunu girerek çözebiliriz.
Ama bunun daha kolay bir yolu var.
Non-Breaking space denilen komutu
Command+Shift+Space (Crtl+Shift+
Space) tufl kombinasyonu ile çal›fl›yor. 

Tüm Flash Dosyalar›n› Kolayca Oynat›n
Dreamweaver’da sayfan›za bir Flash
dosyas› ekledi¤inizde, dosya üzerinde
Flash simgesi olan gri bir simge ile gö-
rülür. Properties panelindeki Play tu-
fluna bast›¤›n›z zaman o animasyonu
izleyebiliriz. Ancak sayfan›zda birden
çok Flash dosyas› olabilir. Hepsini te-
ker teker görmeye çal›flmak yerine,
Shift + Option + Command + P (Win-
dows’ta Ctrl+Alt+Shift+P) tufl kombina-
nasyonu kullanarak ayn› anda bütün
Flash dosyalar›n›z› oynatabilirsiniz.

FLASH T‹PLER‹
Bandwidth Profiler
Bandwidth Profiler ile haz›rlad›¤›n›z
sayfalarda yüklenme sorunu ç›karta-
cak kareleri kolayl›kla tüm özellikleri
ile görüp optimize edebilirsiniz. Bunun
için çal›flman›z› bitirdikten sonra
CTRL+Enter’a basarak test moduna
geçin. Test modunun toolbar›ndaki Vi-
ew > Bandwidth Profiler komutu ile
uygulamay› çal›flt›r›n. Aç›lan panelin
sol taraf› film, sa¤ taraf› ise frame özel-
liklerini gösterir. 

Dim, filminizin boyutlar›n›; Prelo-
ad, taray›c›ya yüklenme süresini; Lo-
aded, o anda yüklenen frame say›s›n›
ve yüzdesini verir. Animasyonunuzda-
ki karelerin yatay k›rm›z› çizgiyi geç-
memesine özen gösterin. 

Debugger Kullan›n
Debugger bir movie, player’da oynar-
ken hatalar› bulup düzeltmenizi sa¤la-
yan bir paneldir. Debugger actionsc-
ript kodlar› içinde breakpoints olufl-

turman›za izin verir. Bu noktalar yaz-
d›¤›n›z actionscript kodlar›n› s›nama-
n›z› sa¤lar. Aktive edildi¤inde status
barda URL adresi veya klibin bulun-
du¤u lokal yolu, movie klip listesini,
debugger›n serverda m› yoksa lokal
playerda m› çal›flt›¤›n› görebilirsiniz.
Mevcut animasyona bir klip eklendi-
¤inde veya ç›kart›ld›¤›nda bu ifllem he-
men animasyona yans›yacakt›r. Test
modunda Debugger› aktive etmek için
Control > Debug Movie’yi seçin. Movie
test modunda iken debugger paneli de
aç›lacakt›r.

Flash’da Dosya Boyutunu Azaltmak
Animasyonlar›m›z›n yay›nlanabilmesi
için Flash dosyam›z›n boyutunun kü-
çük olmas› gerekir. Bu nedenle, gradi-
ent renkler ve alfa saydaml›¤›n› dik-
katli kullan›n. Paneldeki solid renkleri
tercih etmeye çal›fl›n. Gereksiz yere bir
sürü sembol ve keyframe kullanma-
y›n. Kullanmad›¤›n›z sembolleri lib-
rary’nizden silin. Bitmap’leri vektörel
hale getiren Trace Bitmap komutunu
az renkli bitmap’lerde kullan›n. Farkl›
desenli özel çizgilerden uzak durun.
Haz›rlad›¤›n›z çizgileri seçerek menü-
den Modify > Optimize komutu ile sa-
delefltirin. De¤iflik font stillerini ayn›
anda kullanmak yerine, sistemde bu-
lunan az say›da font çeflidi tercih edin.
Dosyay› yay›nlamadan önce Publish
Settings bölümünde, JPEG kalitesini
varsay›lan de¤er olarak 50’de kullan-
may› tercih edin.

Layer’lay›n Rahatlay›n
Bol layer kullan›m›ndan zarar gel-
mez. Çünkü layer’lar dosya boyutunu

etkilemezler. Tam tersi herfle-
yin tek bir katmanda olmas›
animasyonun yüklenimini zor-
laflt›r›r. Ek sahneler yerine de
layerlar› kullanabilirsiniz. Sah-
ne say›s› fazla olan Flash dos-
yalar›n›n da browserlar taraf›n-
dan okunmas› zaman al›r. Üs-
telik kesintili olarak okunma
riski tafl›rlar. Bir de genifl bir
alanda yap›lm›fl bir Flash ani-
masyonunda ayn› anda bir çok
nesneye hareket vermeyin.

Yüklenmesi zorlaflacak ve bu da per-
formans› düflürecektir.

MX’de Movie’leri Maskeleme
Flash 5’de maskeleme yapmak için
üstte bir mask layer› ve onun alt›nda
bir masked layer’› gerekiyordu. Mask
layer›nda maskeleme için sadece bir
dolgu veya metin kullan›labilirdi. MX
versiyonuyla ise bir movie’yi di¤er bir
movie üzerinde maske olarak kullan-
ma flans›m›z var. Bu ifllem için kat-
manlara mask veya masked özelli¤i
vermek yerine Timeline’a flu komutu
vermemiz gerekiyor: 
maskelenen_klip.setMask(maskele-
yen_klip);

Maskeleme Komutu
Maskeleme ile belirli bir alan› seçip ar-
kas›ndan baflka nesneler görünmesini
sa¤lar›z. Maskeleme için iki tane layer
gerekiyor (en az). Üstteki mask, alttaki
ise masked layer›d›r. Önce bir resim
import edelim ve bunun hemen üstü-

ne bir layer ekleyelim. Sonra oval ara-
c› ile 2. layera bir daire çizelim. fiimdi
de layerlara özellik atayal›m. En üstte-
ki daireli layer› seçin. Modify > Layer
komutunu verin. Aç›lan menüden
“Mask”› iflaretleyin. Resmin bulundu-
¤u layera ayn› ifllemi yap›n, fakat
“Masked” komutunu iflaretleyin. ‹ki la-
yer› da kilitleyin ve mask›n›z haz›r.

Filminizi Multimedya Ortamlar›na Aktar›n
Sunumlar›n›z için kullanaca¤›n›z
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Flash filmlerinizi CD-ROM üzerinde
tafl›yabilirsiniz. Flash filminin tümünü
içerisinde bulunduran .exe Projector
dosyas› ile Flash playera da ihtiyaç
duymadan sunum yapabilirsiniz. Bu-
nun için File > Publish Settings komu-
tu seçilir. Aç›lan menüden Windows ve
Macintosh için gerekli olan projector
dosyalar› oluflturulmas›n› sa¤layan se-
çenekleri aktif hale getiririz. 

Özel Font Kullan›m›
Tasar›m›n›zda özel bir font kullanmak
istiyorsunuz. Ama her font her bilgisa-
yarda olmad›¤› için kullan›c›lar fontu-
nuzu do¤ru görüntüleyemeyebilir.
Ama, fontu library’ye ekleyerek çal›fl-
mam›z içinde tan›t›rsak sorun ç›kmaz.
Bunun için önce (yeni bir dosya, son-
ra da) Window > Library komutuyla
as›l menümüzü açar›z. Library > Opti-
ons > New Font komutular›n› t›klar›z.
Gelen panelden kullanaca¤›m›z fontu
seçer ve ona bir isim veririz. OK tuflu-
na bast›¤›m›zda fontumuzu çal›flma-
m›z›n içine alm›fl oluruz. Ekledi¤imiz
font Library içinde olacakt›r. En iyi so-
nuç için pixel fontlar› Dynamic Text
olarak kullan›lmal›d›r. 

Flash MX ile ScrollPanel Örne¤i 
Bir movie’yi action script içinde kullan-
mak için, pencerenin sa¤›ndaki Com-
ponents panelini açar ve sahnemize
sürükle b›rak yöntemiyle bir scrollpane
koyar›z. Bu paneli seçip Properties’deki
Parameters sekmesini t›klar›z. Instan-
ce name bölümüne bir ad veririz. Son-
ra ana sahneye döner ve New Symbol
komutunu veririz. Aç›lan panelde Mo-
vie Clip seçene¤ini iflaretler ve bir isim
veririz. Advanced bölümünden “Export
for ActionScript”i seçeriz. Identifier bö-
lümüne moviemizin ismini yaz›p OK’i
t›klar›z. Ana sahneden scrollpane’i se-
çeriz. Parameters’den Scroll content’e
t›klay›p yaz›m kutusuna movie’nin is-
mini yazar›z. Scroll Horizontal ve Verti-
cal k›s›mlar›na t›klayarak auto, true,
false seçeneklerinden istedi¤imizi kul-
lan›r›z. Moviemizi aç›p istedi¤imiz met-
ni yazarak ifllemi tamamlar›z.

Movie Clip ile Çal›fl›n
Ayn› animasyonu filminizde birkaç de-
fa kullanmak istiyorsan›z, en pratik
yol onu bir movie clip olarak kaydet-
mektir. Bunun için Insert > New
Symbol komutuyla gelen menüden
Movie Clip seçilir. Bu dosyan›n içine
(layer’a) animasyonumuz konulur.

Böylece, örne¤in hareketli bir nesneyi
filminizin her yerine koyabilirsiniz. 

Flash’da Video Dosyalar›
QuickTime ile Çal›flmak
Flash MX’in di¤er versiyonlar›ndan en
önemli farkl›l›¤›, bir avi veya mov dos-
yas›n› swf içine gömme flans›na sahip
olabilmesidir. Fakat bilgisayar›n›zda
QuickTime yüklü de¤ilse bu formatta
dosyay› Flash içine alamaz ya da bir
swf dosyas›n› MOV format›nda export
edemezsiniz. QuickTime dosyas› Flash
içine al›nd›¤›nda ses özelliklerini kay-
beder. Bunun için düzenlemeleri yap-
t›ktan sonra MOV format›nda yeniden
kaydetmek gerekir. Flash, içine import
edilen bir QuickTime dosyas›n›n dü-
zenlendikten sonra swf format›nda ka-
y›t edilmesine izin vermez.

QuickTime Dosyas› Alma
Import komutundan önce QuickTime
dosyas›ndaki frame say›s› kadar fra-
me’i timeline’a kaydetmelisiniz. Bunun
için basit bir matematik hesab› ile 5
saniye olarak görülen animasyona
karfl›l›k gelen filmin kare/sn oran›na
bak›l›r. Varsay›lan de¤er 12 kare/sn.
oldu¤undan flöyle bir hesap yap›l›r.
Filmin uzunlu¤u 5sn x 12 kare/sn=60
frame eder. 60 adet bofl frame’i timeli-
ne’a ekleyerek ve dosyay› File > Import
komutu ile import edin. E¤er fazla fra-

me eklemiflseniz sahne üzerine filmin
bitti¤ini gösteren zarf fleklindeki yer
tutucuyu göreceksiniz. Bundan sonra-
ki frameleri silmelisiniz.

QuickTime’lar› SWF’ye Dönüfltürün
Quicktime dosyas›n› swf format›nda
kaydetmek için önce QuickTime dos-
yas› Flash içine al›n›r. Sonra, File >
Export Movie komutunu ile aç›lan me-
nüden dosyaya bir isim verilir ve for-
mat olarak Windows için Bitmap sequ-
ence, Mac için PICT sequence seçene-
¤ini kullan›l›r. Kaydet butonuna bas›l-
mas›yla Export Sequence Paneli aç›la-
cakt›r. Ekran çözünürlü¤ünü ayarla-

mak için match screen butonuna ba-
s›n. Color Depth ayar›n› yap›n. Smo-
oth iflaretleyin ve tamam› t›klay›n.
Flash tüm frameleri bitmap’e çevirir ve
s›ra ile kaydeder. Sonra ayn› boyutlar-
da bir Flash sayfas› aç›n. File > Import
komutu ile kaydedilen bu bitmaplerin
ilkini iflaretleyin. Flash ard›fl›k bit-
maplar› hat›rlar ve bir uyar› paneli ile
“hepsini import etmek istiyor musu-
nuz?” diye sorar. Tamama bas›l›nca
hepsini Flash içine al›r. Art›k swf for-
mat›nda kay›t yapabilirsiniz. 

Mac’e de PC’ye de Uygun Olsun
Bir swf dosyas›n› mov olarak kayde-
derken yapaca¤›m›z ufak bir hareketle
dosyam›z hem Mac’e hem de Win-

dows’a uyumlu hale gelebilir. Bunun
için File > Export Movie komutunu se-
çip gelen paneldeki ayarlamalar› yapa-
l›m. Kaydet komutuyla aç›lan Export
QuickTime Paneli’ndeki Flatten para-
metresini iflaretleyelim. Tamamd›r.

Yaz› Karakterlerini SWF Dosyas›na Ekleyin
Dinamik metin kutular›  tasarlarken,
be¤endi¤iniz fontlar›n daha estetik gö-
zükmesini istiyorsan›z, fontlar› mutla-
ka Character Options seçene¤i yard›-
m›yla SWF dosyas›na ekleyin. Charac-
ter Options, Properties > Dynamic Text
ile gelen Character butonuna t›klana-
rak ulafl›l›r. Fakat, Flash dosyas›na
eklenen yaz› tipi, dosya boyutunun
büyümesine neden olur. Bu nedenle
karakter belirlerken “Only” seçene¤ini
seçmek ve sadece kullan›lan karakter-
leri “And these characters” kutucu¤u-
na girmek gerekir ki, böylece swf dos-
yas›n›n boyutu da düfler. 

Metninizi Kopyalatmay›n
Uygulama haz›rlan›rken, metin kutu-
lar› için  Selectable özelli¤inin kapal›
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olmas› gerekir. Çünkü bu özellik aktif
oldu¤unda metin kutusu içindeki me-
tin, ziyaretçi taraf›ndan seçilip kopya-
lanabilir hale gelir. Ayr›ca Selectable
özelli¤i aktifse metnin anti-aliase mo-
du da kapal› olacak ve bu da metnin
kötü gözükmesine neden olacakt›r.
(Ab) fleklinde bir ikona sahip olan se-
lectable seçene¤i, Static, Dynamic ve
Input fleklindeki tüm metin kutular›n-
da kullan›labilir. 

Internet’te Nas›l Görünece¤ine Bak›n
Yapt›¤›n›z bir animasyonu test etmek
için, Control menüsü alt›ndaki Test
Movie komutunu kullanman›z gerek-
mektedir. Ama filminizi Internetten in-
diriyormufl gibi görmek için, Test Mo-
vie aç›kken View > Show Streaming ko-
mutunu aktif hale getirmek gerekiyor.

Butonlara Ses, Bebelere Balon
Butonlara t›kland›¤›nda ses ç›karma-
s›n› sa¤lamak için, önce buton sembo-
lünün çal›flma alan›na geçeriz. Down
karesine bir ses dosyas› ekleriz. File >
Import menüsü üzerinden MP3 dosya-
lar›n›z› sayfalara ekleyebilirsiniz. Bu
yolla ses dosyas› Flash filminin lib-
rary’sine otomatik olarak eklenir. 

Library’ler Aras›nda Nesne Al›flverifli
Baflka bir Flash dosyas›na ait nesnele-
ri ve sembolleri, üzerinde çal›flt›¤›n›z
projeye tafl›mak için File’dan Open As
Library komutu seçilir. Buradan sem-
bollerini istedi¤iniz dosya seçilir. Di¤er
dosyan›n library’si de mevcut lib-
rary’nizin yan›nda aç›l›r. ‹stedi¤iniz ça-
l›flmay› mevcut library’ye sürükleyerek
tafl›yabilirsiniz.

FIREWORKS T‹PLER‹
Fireworks ile Banner Yap›m›
Banner yapmak için önce, banner’›m›-
z›n boyutuna uygun yeni bir sayfa
açar›z. Sonra ilk karede yer alacak

“Macline” yaz›s›n› sayfaya girelim.
‹kinci karemiz için Frames and History
panelinden Add Frame komutunu se-
çiyoruz. ‹kinci kareye, ilk karemizde
yazd›¤›m›z “Macline” metininin yan›na
“Her Ay Bayilerde” metini yazal›m. ‹ki
metni tek bir metin gibi görmek için
ayn› panelin sol alt köflesinden “onion
skinning” butonunu t›klar›z. Aç›lan
menüden “Multi frame editing” ve
“Show all frames”i iflaretleriz. Yeni bir
bofl kare ekleriz. Bu üçüncü kareyi di-
¤er karelerin üstüne yerlefltiririz. Win-
dow > Optimize menüsünden resim
format›m›z› “Animated GIF” olarak be-
lirleyince banner’›m›z haz›rd›r.

Fireworks MX’te Pop-Up Menü Yapmak
Pop-up menü yapmak için ifle önce bir
yaz› ya da bir nesne oluflturarak bafl-
lar›z. Seçti¤imiz nesneye sa¤ tuflla t›k-
lay›p Modify > Symbol > Convert to
Symbol komutunu veririz. Gelen me-
nüden “Button”u seçer ve OK’e basa-
rak devam ederiz. Yeflile dönen nesne-
mizin ortas›nda ç›kan imlece basarak
“Add Pop-up Menu” deriz. Karfl›m›za
gelen pencereden menü için istedi¤i-
miz ayarlar› yapar›z. File > Export  ko-
mutu verip menümüzü “HTML and
Images” olarak ve Slices k›sm›nda “Ex-
port Slices”› seçerek kaydederiz.

Pratik Rollover Buton Yap›m›
Fireworks’ün butonlar için özel bir kü-
tüphanesi bulunuyor. Bu haz›r buton-
lar› kullanmak için önce, butona uy-
gun ölçülerde yeni bir sayfa açal›m.
Sonra Edit > Libraries > Buton komu-
tu ile aç›lan menüden istedi¤imiz bu-
tonu seçelim ve Import tuflu ile seçimi-
mizi tamamlayal›m. Bu flekilde seçti¤i-
miz buton alan›m›za gelecektir. Fire-
works Libraries’inde Buton d›fl›nda
Animation, Bullets ve Themes taslak-
lar› da mevcuttur.

Resmin Orijinali mi Kay›p?
Fireworks dosyalar›n›z›n orijinallerini
kay›p m› ettiniz? Telafla kap›lmay›n.
Çünkü Fireworks, aktar›lm›fl HTML
dosyalar›ndan bir PNG dosyas›n› yeni-
den oluflturulmas›na imkan veriyor.
Bunun için, File > Reconstitude Table
komutunu vermemiz gerek. Aç›lan
menüde, yeniden oluflturmak istedi¤i-
miz görüntüyü içeren HTML dosyas›n›
buluruz ve OK’i t›klar›z. Program grafi-
¤i bileflen parçalar› ve dilimlerden ye-
niden oluflturur. Art›k, istedi¤iniz de¤i-
flikli¤i yapabilirsiniz. 

Resmi Bir fiekle Yerlefltirmek
Fireworks’de daire, kalp, üçgen gibi
çeflitli flekillerin içine bir resim ekleye-
bilirsiniz. Önce istedi¤iniz flekli araç
çubu¤unu kullanarak çizin. Sonra
kullanaca¤›n›z foto¤raf› aç›n. Foto¤ra-
f›n tümünü ya da kullanaca¤›n›z k›s-

m›n› seçin ve kesin. Çizdi¤iniz flekli
Edit > Paste Inside komutu ile yap›flt›-
r›n. Resminiz fleklin içinde ve flekille
bütünleflmifl durumda. Gölgelemeyi
unutmay›n.

Photoshop Eklentilerini Kullan›n
Photoshop eklentilerini Fireworks’de
de kullanabilirsiniz. Bunun için, Fire-
works üzerinde çal›fl›rken Edit > Prefe-
rences > Folders talimat›n› uygulay›n.
Burada Browse’› t›klay›n ve Photoshop
Plug-Ins lokasyonunu belirleyin. Art›k
bu eklentileri Fireworks’ün Effects pa-
letinde kullanabilirsiniz.

KODLAR VE D‹⁄ERLER‹
Tarac›y› Boyutu
Malum Web’de herkes farkl› ekran çö-
zünürlü¤ünde geziniyor. Bu durum ta-
sar›mc›lar›n iflini biraz zorlaflt›r›yor.
Yapt›klar› tasar›m› çeflitli çözünürlük-
lerde kontrol etmek isteyenler tasar›m-
c›lar bir Browser Sizer program› kulla-
nabilirler. Bu minik uygulama ile fark-
l› browserlarda, farkl› çözünürlükte
sayfalar›n›z› test edebilirsiniz. Bunun
için http://www.applythis.com/ adre-
sini t›klaman›z ve uygulamay› indir-
meniz gerekiyor.

Vakit Nakit
Büyük grafikler, kompleks tablo yap›-
lar›, ses dosyalar›, Java appletleri gibi
özellikler sayfan›z›n geç aç›lmas›na
neden olur. Sebep ne olursa olsun zi-
yaretçiler bekletilmeyi sevmez. Siteni-
zi ilk defa ziyaret eden birinin sayfay›
bekleme süresi ortalama 30 saniye-
dir. Özetle, anasayfan›z 45K’dan fazla
olmamal›.
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Sayfan›z› Afl›rtmay›n
Sayfan›z›n baflka bir sitenin çerçevesi
içinde zorla al›konulmas›n› istemiyor-
san›z, afla¤›daki tag› sitenize ait tüm
sayfalar›n META tag›n›n içine koyma-
n›z› öneririz. 
<META HTTP-EQUIV=”Window-target”
CONTENT=”_top”>

Pencerelerinizi Kontrol Edin
Açt›¤›n›z yeni bir browser penceresinin
niteliklerini kodlar yard›m›yla diledi¤i-
niz gibi kontrol edebilirsiniz. Afla¤›daki
kod, yeni bir pencere aç›lmas›n› ve
pencereye “yenipencere.htm” sayfas›-
n›n gelmesini sa¤lar. Kodun geri kalan
k›sm› ise pencerenin di¤er özellikleri-
nin belirlenmesini sa¤lamaktad›r.
<a href”” onClick=“window.open (‘yeni-
pencere .htm’ , ‘newwindow’ , ‘he-
ight=620,width=840,toolbar=no,me-
nubar=no,scrollbars=yes,resizab-
le=yes,location=no,directories=no,sta-
tus=no’)”>

Türkçe Karakter Kodu
Haz›rlad›¤›n›z Web sayfan›z›n browser-
larda sorunsuz görünmesi için karak-
ter kodlar›n›n META tag›nda verilmesi
gerekir. Türkçe karakterlerin görün-
mesini sa¤layan karakter kodlar›, Mac
ve Windows için ayn›d›r. Sayfan›z›n
Machintosh’da sorunsuz görünebilme-
si için, ISO kodunun windows-
1254’den önce yaz›lmas› gerekir. Yani;
<META http-equiv=”Content-Type”
CONTENT=”text/html; charset=8859-
9”>
<META http-equiv=”Content-Type”
CONTENT=”text/html; charset=win-
dows-1254”>

Harici Kodlara Ulaflmak
Kodunu istedi¤iniz Web sayfas›n›n
kaynak sayfas›n› aç›n (View > Source).
Harici koda ait referans› bulun (genel-
de <head> tag’› içinde <script> (javasc-
ript) ve <link> (CSS) ile bafllayan tag-

lard›r). Browser’›n Adres/Location bö-
lümüne kodun (“ ” içinde belirtilen ve
e¤er varsa ../ s›z k›sm›n›) linkini, site-
nin URL’sinin sonuna ekleyip “enter”
derseniz harici kod için bir kay›t etme
istemi gelecektir. Bunu notepad’de
açarsan›z harici koda ulaflm›fl olursu-
nuz. (Baz› browser’lar direk de kodu
açabilir.)

Banner Tasar›m›nda Yaz› Karakteri 
Bir banner tasarlarken kulland›¤›m›z
yaz› karakterinin türü, yaz›lar›n kolay
okunmas› için büyük önem tafl›r. Çün-
kü, ziyaretçiler banner’lara çok k›sa
süreli bakarlar. E¤er kolay okunulur-
luk sizin için önce geliyorsa “Sans Se-
rif”, hatta “Bold Sans Serif” font kul-
lanmak do¤ru olacakt›r. Çünkü “Sans
Serif” karakterler daha az flekil içer-
mekte ve bu sebepten dolay› daha ko-
lay alg›lanabilir ve daha h›zl› okunabi-
lir olmaktad›r. Ürün kimli¤inin öne
ç›kt›¤› durumlarda ise “Serif” karak-
terleri  kullan›labilir. 

‹maj Stratejileri
256 de¤il 216 Renk Paleti
Siteniz yüksek sistemlerle çal›flan bir
kitleye hitap ediyorsa renk paleti ko-
nusunda endiflelenmenize  gerek yok.
O halde, neden 256 yerine 216 renk?
Çünkü, kalan 40 renk eski Mac ve
PC’lerde görüntülenmedi¤i ve Web
browserlar›ndaki renk yönetim sistemi
8-bit’i yani 216-renk paletini destekle-
di¤i için. Bilgisayar kullan›c›lar›n›n ya-
r›s› da hala 16-bit renk göstergesini
kullanmakta. Bu nedenle, GIF’lerinizi
mümkün oldu¤unca transparan
background ile kullan›n ve HTML
renklerinden mümkün oldu¤unca ayr›
tutun. Sayfalar›n›zdaki background ve

tablolar›n Web Safe renkle-
riyle kullanmaya çal›fl›n. 

GIF Foto¤raflar› 
Tam renk bir imaj›, 8-bit
(256 renk) Gif dosyas›na
dönüfltürürken, Photos-
hop’un 256 renk seçmesine
izin vermifl olursunuz. Bu
en yüksek Gif imaj kalitesi-
dir ama baz› dezavantajlar›
da vard›r. E¤er sitenizi ziya-
ret eden kiflinin monitörü

her seferinde 256 rengi gös-
termeye ayarlanm›flsa, brow-
ser› imaj› 216-renk browser
paletini kullanarak açmaya
çal›flaca¤›ndan resim bozul-

maya u¤rar. Bu sorunu halletmek için
tüm renkli grafiklerinizi 216-renk
browser paleti kullanan Gif dosyalar›-
na dönüfltürmelisiniz. Bu flekilde
imajlar›n›z›n nas›l görüneceklerinden
emin olabilirsiniz. Ya da bunun yerine
JPG dosya format›n› kullanabilirsiniz.
JPG’nin imaj s›k›flt›rma format› Gif’in-
kinden daha etkilidir. 

JPEG Foto¤raflar›
JPEG dosyalar› tam renk (24-bit) imaj-
lard›r, bu nedenle de dosyaya ait do¤-
ru korurlar.  Ne var ki, JPEG imajlar›-
n› 8-bit ekranlarda yaflad›lar› dithe-
ring’e karfl› koruman›n bir yolu yok.
Dithering, imaj kalitesi ile uzlaflama-
yan JPEG imajlar›nda görülür. JPEG
format›nda standardize edilmifl her-
hangi bir fotografik, di¤er tam renkli
foto¤raflar ya da grayscale imajlar›
JPEG s›k›flt›rmas› için uygundur. 

PNG Grafikleri
Portable Network Graphic uzun adl›
PNG grafikleri grafik yaz›l›m gelifltirici-
leri konsorsiyumu taraf›ndan gelifltil-
mifl Gif imaj format›na rakip bir dosya
format›d›r. PNG format› özellikle Web
sayfalar›nda kullan›lmak üzere geliflti-
rilmifl bir format. Bu format pek çok
özelli¤i destekliyor (ör: transparan
özelli¤i gif’ten daha iyi) ancak ne yaz›k
ki kendisi henüz browserlar taraf›n-
dan tam olarak desteklenmiyor. Böyle
de olsa, PNG’nin gelece¤in Web grafik
format› olaca¤› düflünülüyor. PNG ay-
n› zamanda Fireworks’ün de standart
kay›t format›. 

Thumbnail Boyutu
Thumbnail’ler için ideal ölçü pek çok
monitörde rahat alg›lanabilen 75 pi-
xel’dir. 

GIF’leriniz Interlacing ile Yüklensin
Resim dosyalar› browserlara sat›r sat›r
yüklenirler. Bir GIF dosyas›n›n özellik-
lerinde Interlacing seçene¤i aktif edilir-
se, resim browserda önce net olmayan
hatlarla görüntülenir. Dosya yüklenir-
ken resmin niteli¤i yavafl yavafl artar.
Bu da sayfan›n ziyaretçilerinin vakit
kaybetmemelerini sa¤lar. Böylece
uzun süre resmin tam olarak yüklen-
mesi önlenmifl olur. ML
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